AA File Missing Error


Rhythmyx Version: 5.7.1

A customer has reported a problem when trying to edit content items using a particular variant via Active Assembly. The error is:

An exception occurred while processing the whitebox XML document through the file:dw_general_index_cas/edit/p_event_index.xsl style sheet: java.io.FileNotFoundException: dw_general_index_cas\edit\p_event_index.xsl (The system cannot find the file specified)

When checking in the appropriate folder in the Rx tree the file is indeed missing (although we have no idea why). I’ve tried adding/updating the variant again via the workbench in the hope that this would re-create the .xsl file automatically but that hasn’t worked.

There are no additional errors (that I can find - I’ve checked console.log and set up tracing on the assembler application) and there are two other page variants in the application that are fine.

Does anyone know how I can re-create the file required for AA or know of any other logs that may contain further information?

Thanks in advance.

These files are created by the Active Assembly process when you first enter AA (through the menu). How are you getting to the URL? Are you going through the AA menu or previewing it directly?


I just use the AA menu in content explorer.

I think I may have fixed this in a work-around sort of way.

I created a new assembler application & created the variant again. When I previewed the content item via the AA menu using this new variant, a new edit file was generated. I copied that new edit file into the folder of the original variant and it seems to have done the trick.

I’m not sure whether, because the edit file was actually generated for a different variant, this may cause problems in the long run but so far it seems to work without any problems.