Can not approve or publish a specific page without errors

I can not approve or publish a specific page without seeing user related errors. It is only happening on one page. I have attached a screenshot.


This type of error typically indicates a database mis-match where CM1 is looking for something that’s not syncing properly in your back end. There are a couple things you can try to attempt to resolve this. First, with the page open in CM1, hover over View, click Revisions, and attempt to restore an earlier revision of your page, then see if you can work with that.

The second thing you can try is, with the page highlighted in the Finder, click the gear icon and select Copy. This will create a copy of your page with updated revision information in your database, and you should be able to approve and publish this copy of your page as normal. If that works, at this point you can delete the old page and rename the copy to the same name as the original. If page this is a section landing page, in the navigation tree view you can drag and drop the functional copy of this page onto the appropriate section to set it as your updated section landing page.

Let me know if any of this is helpful.

I ran into issues with the copy as well. I’ve attached a screen shot. I attempted to restore to an earlier version as well but it gave me similar errors. I’m attaching a screen of the copy issue.

Making a copy did not work as whatever issues the original had carried over. I instead created a page from scratch and copied the elements over. I dragged it into the navigation point as it was a landing page. This worked. Now the original page is saved as index (1). I would like to delete index (1). But I’m getting the same error. I’ve attached a screenshot. Any suggestions?


I got a new error when trying to change publishing environments. I have attached it below.
At this point I can no longer do my work in percussion. I will need to avoid using it as I’m very worried about losing all my work.

This does sound like a database issue. I am going to create a support ticket so we can take a closer look at your environment and see what we can do to correct this. Please check your inbox momentarily for a notification from our support portal.

I am getting errors that are not allowing me to approve a page that I think are related to this topic. The original error is “Failed transition due to server error.” when I try to Approve a page. I have tried making the assets shared but I only receive the option check box on one of the five asset screens. I try to delete the assets from the page but never see the edit pencil icon or delete icon appear in the widget box when I click it after clicking the Edit button. I have tried changing the template in hopes the assets would be added to the Unused assets option…no change would take place, the file would keep the existing template. I have tried copying the file but the duplicate never shows up in the finder. I have tried reverting to previous versions and receive the same error when attempting to approve the page. The page that is having problems is a section index page so deleting it and rebuilding is a major pain since there are multiple folders and pages under this page. Unless I am not aware of a function, if I delete this page I have to rebuild it from the main Navigation view and then relink everything that was attached to or referencing this now broken page.

Suggestions? Fixes?


Hello Jerome,

We have opened this as a trouble ticket in our system, and will contact you regarding this.

Thank you,

In case other customers encounter similar issues, basically what appears to have happened here is CM1’s connection to the SQL database was dropped while Avi had been editing content on this particular page. This led to an item mis-match in the database, causing the revision and content id error we see in his first screenshot when attempting to approve or publish the page.

To resolve this issue you you have two options. Either you can convert all of your page’s local content into Shared Assets, or you can delete and then recreate all of the page’s local content (for the most part, this is a simple copy and paste process).

To convert your local content into Shared Assets, simply edit the local content and select the Shared Asset check box at the bottom of the edit window. Once you’ve done this, save the asset, at which point you will be prompted with a Save As menu, through which you can specify a name and location for your asset. Once all of your local content has been converted into Shared Assets, you should be able to Publish / Workflow the page without any further problems.

Alternately, to delete and then recreate all of the page’s local content you will want to first identify all of the widgets that contain local page content (typically Rich Text widgets, maybe some HTML widgets). Then, one-by-one, open up these widgets for editing, copy out all of the contents – for Rich Text widget, be sure to copy the output of the source view – then cancel out of the editor. From here, select the widget again, and then hit the blue “X” button to the upper right to delete local content.

Once you’ve done this, open up the empty widget in the editor and paste the original content back in. For Rich Text widgets, again be sure to paste the contents of the source view back into the source view. Once this has been completed, hit save.

This process has the effect of manually reestablishing the proper id relationship in the database. Once you have followed these steps for all of your local page content, you should have no trouble approving and publishing (or deleting) your page as you would have before this database issue occurred.

One thing to note, as you see in Avi’s first screenshot, is that he also had local content present in the Unused Assets tray, which took a little bit of poking around until we realized there was still local content hiding away that we hadn’t touched. Once we removed the assets from the Unused Assets tray, we were able to delete the page without issues.