Copying a page hangs Percussion

When I copy my index page, the system hangs. I can click on the icon that gives me the choice to copy (the gear icon) and when I click on “Copy” it highlights and then the menu stays there and nothing seems to happen. Eventually I close the browser, but when I log back in it won’t open the main site - it just keeps spinning. Is my page corrupted?

This started happening last week when there were two of us logged in with the same username. I don’t know if that caused the problem, or if it is a coincidence.

I just tried copying a different page, and it did not hang. So there must be something wrong with my individual page. Do I need to start over?


This may be due to a revision mis-match affecting a piece of local content on your page. What happens if you open up the page for editing and attempt to either Submit, Approve or Archive the page?

It let me click the approve button. Then I could click the archive button. It didn’t hang. But I am just starting to play with CM1, so I don’t know what those buttons do. Should I try copying it again?

I just tried to add a widget and the highlighting wouldn’t show up where I wanted to add it, so I disabled Javascript. This set off an endless cycle of “transferring data from” our server, and “waiting for” our server. Experience tells me that I have to close the browser window.

Being able to successfully workflow the page indicates that this is not the revision mis-match issue I mentioned, which is good. As a next quick test, can you log out of CM1, clear your full browser cache, and then log back in and attempt the operation again? Sometimes erratic behavior with the CM1 user interface can be caused by improperly cached login sessions, so I want to eliminate this as a cause.

The page copy worked this time, so I guess that was the problem. Is there a list of troubleshooting tips, or is this board the best way to get help?

Glad to hear that this was a simple fix. If your question / issue can’t be addressed by a quick search on, then yes, this board should be your next stop. That’s what we’re here for!

Except that it looks like the act of copying the page deleted my local content from the (original) page. This shows up as the HTML (or RTF) area being empty.

Peggy, the copy function will create a copy of the last approved revision of that page. You’ll want to make sure you hit the Approve button on the original page before copying it, otherwise you might create a copy of an outdated revision.

As part of our troubleshooting, I did hit the Approve button. Please understand that the content has disappeared from the Original page. (It also is not present in the copy).

Peggy, I understand, I misread your message initially. I’ve never encountered a scenario where the act of copying a page will delete local content on the original page. Is the content also gone from the new copy of the page?

One thing you can check is, when you have the original open in the editor, hover over View and select Revisions. If there are multiple revisions, try previewing older ones by selecting the magnifying glass icon to see if the local content still exists in an older revision. If it does, you can select the “Restore this revision” icon to make that revision the current revision.

The content is gone from the original page and is not present in the copy. The only revisions are from yesterday when I approved the page for the first time. The content is not there in any revision, though it WAS on the page late yesterday.

This is very strange. Can you verify that the content appeared on the page just before you attempted to copy it, or was there a period of time between when you last edited the page and then attempted the copy? You mentioned other users working in the system – is it at all possible someone else might have edited this page and accidentally deleted the content? Lastly, do you have this content stored locally anywhere so you can easily replace it (in which case your main concern here is with ensuring that no content disappears in the future)?

I don’t actually know when the content disappeared. It was there at 5:15 last night. The library closed at 5:30, it is gone this morning. No one else should be touching that page, and the other person who works with me doesn’t come in until this afternoon. I don’t believe anyone else deleted it. Although it is possible that the page was open under my account at 5:15, when I made a change under John’s account downstairs. Maybe it is a “two people working on the same piece at the same time” problem? How much concurrency testing have you done?

We are very much in the experimentation phase. I can recreate the content (though, of course I would rather not). But I’m worried about the future.


Peggy, we have many customers who often have quite a few users working in their instances simultaneously, and I have never heard of content disappearing in the manner you’ve described. While I’m glad the content here was only for experimental purposes at this point, I certainly understand you concerns. Please let me know as soon as possible if anything like this happens again, and we can explore this in more depth if need be.

Trying to recreate this content, but all I see is blank even though there is HTML in the widget. I replaced the HTML with just an and was able to display an image, but when I tried to put a target on the image and saved the widget, it gave me an error while the processing wheel kept turning:
This XML file does not appear to have any style information associated with it. The document tree is shown below
An exception occurred while processing the internal request handler call: An error occurred processing the update submitted by session id fd09ee34a365alfa7a59d7ba42c8afbe54fla650. [1] 23000: Cannot insert the value NULL into column "WORKFLOWAPPID’, table 'cm1.dbo.CONTENTSTATUS SET

Something is broken…

Peggy, yes it does appear that this local content might have gotten corrupted in some way. I’m going to go ahead and create a support ticket so we can looking into this issue in more depth. Please check your inbox momentarily.

To close off this thread, we discovered that Percussion had been intermittently losing its connection to the SQL database, causing the issues with content disappearing / not updating. Improvements / updates to their local network appear to have resolved these issues.