Packet for query is too large error message

Percussion shows this message:
This XML file does not appear to have any style information associated with it. The document tree is shown below.
and this is the error message displayed beneath it:
An error occurred processing the update submitted by session id 847812f6fc10e348e68cd15a159cd5d83fffb0de.An exception occurred while processing the internal request handler call: An error occurred processing the update submitted by session id 847812f6fc10e348e68cd15a159cd5d83fffb0de. [1] S1000: Packet for query is too large (15588718 > 4194304). You can change this value on the server by setting the max_allowed_packet’ variable. INSERT INTO bordner.CT_PERCFILEASSET (CONTENTID, REVISIONID, DISPLAYTITLE, ITEM_FILE_ATTACHMENTX, ITEM_FILE_ATTACHMENT_FILENAME, ITEM_FILE_ATTACHMENT_TYPE, FILEUSAGE, FILENAME, ITEM_FILE_ATTACHMENT_EXT, ITEM_FILE_ATTACHMENT_SIZE) VALUES ( ? , ? , ? , ? , ? , ? , ? , ? , ? , ? )modify

I have upped the max allowed filesize on the MySQL server (as I read from another user on your forum), then reset both MySQL and Percussion. I am still getting this message. Any ideas? Do I need to up the max allowed filesize in a Percussion file as well?

Hi John,

It sounds like you’re on the right track. What may have gone wrong is, if you set the max_allowed_packet variable through the MySQL command line, restarting MySQL would actually revert that setting back to what’s contained within your my.ini config file.

To permanently fix this issue, find and open your my.ini file in notepad, which is usually located in a directory similar to “C:\ProgramData\MySQL\MySQL Server 5.6” (note that ProgramData is a hidden folder, so you’ll need to either manually key it in, or set your Windows folder options to show hidden folders), and find this line:


Change this to something greater, such as:


And then restart the MySQL service. Once you’ve done so you should be all set. Let me know if you have further trouble with this.

See below for what the file says right now. I don’t see anything that says 4M. Is it this: SET GLOBAL max_allowed_packet=1073741824
Do I change that line?

For advice on how to change settings please see…

*** DO NOT EDIT THIS FILE. It’s a template which will be copied to the

*** default location during install, and will be replaced if you

*** upgrade to a newer version of MySQL.


Remove leading # and set to the amount of RAM for the most important data

cache in MySQL. Start at 70% of total RAM for dedicated server, else 10%.

innodb_buffer_pool_size = 128M

Remove leading # to turn on a very important data integrity option: logging

changes to the binary log between backups.


These are commonly set, remove the # and set as required.

basedir = …

datadir = …

port = …

server_id = …

Remove leading # to set options mainly useful for reporting servers.

The server defaults are faster for transactions and fast SELECTs.

Adjust sizes as needed, experiment to find the optimal values.

join_buffer_size = 128M

sort_buffer_size = 2M

read_rnd_buffer_size = 2M

SET GLOBAL max_allowed_packet=1073741824
SET GLOBAL connect_timeout=20

Yes, that’s the line you’ll want to modify.

I changed the SET GLOBAL max_allowed_packet=1073741824 to SET GLOBAL max_allowed_packet=500M and saved it. Then I restarted Percussion. I am still getting the same error.

Hey John, did you restart the MySQL service as well after making this change? If so, when you run a query of SHOW VARIABLES LIKE ‘max_allowed_packet’ in MySQL, what value is returned?

It worked! Thanks, we were updating a local file not this global hidden folder.
C:\ProgramData\MySQL\MySQL Server 5.6

No problem, glad to hear it!