Publishing error after upgrading to 5.3.15

The issue:
Ever since we upgraded to the new version (5.3.15 Build 201608P05 (299) [5315_20180301]), we have been getting the following error messages when publishing.  
Thankfully, the publishing jobs ARE actually still going through, but it makes it look like pages aren’t being published, (i.e. the status stays stuck under “Pending”), and it would be nice to get it fixed.

The error message: (See attached picture)
Error for metadataEndpoint: perc-metadata-services/indexer/entry, Item: 123,579,094,027,737, jobId: 41,546, location: /www-staging/events/springsing/index, contentType: text/html;charset=UTF-8, length: 24,536 caused by: Unable to connect to delivery server at: https://localhost:8443.

What we’ve tried:
The issue sounds similar to the one described in this thread here about the DTS:, so as mentioned in that thread, 
and we have tried restarting both Percussion, and the underlying server, but the error message still persists.

Also, for what it’s worth, our license monitor does show our subscription as overlimit, although it should be valid.

Finally, we looked through the logs, and didn’t really see anything besides the error message listed above, but we could have easily missed something, and can provide the logs if it would be helpful.

Please Advise.

Also, I forgot to mention that this is only for pages - assets are like .png images are publishing successfully without any error messages being shown.


Could you verify whether DTS was also upgraded and patched to the same version of CM1 which is 5.3.15 and with latest patch?

Also could you make sure that the DTS is up and running?

Well, we didn’t upgrade DTS with the latest patch because we assumed, (perhaps incorrectly), that we weren’t using it.  (We have a custom transformation pipeline that takes the published output from Percussion, and moves it to our production server)

Can you please tell me how to verify that the DTS is running?  (We’re running Percussion on Ubuntu)

Could try and access the DTS url in the browser?  If it loads the Apache Tomcat landing page, it means dts is running.

Are you talking about the URL https://localhost:8443?

If so, that is blocked by our firewall, so it can’t really be accessed by a browser.  However, I did try a wget on the server itself, and it gave me a connection refused for that address, so I don’t think anything is running there.

This issue was solved by having the DTS server start successfully. 

Having an almost identical issue after updating the DTS with patch 5315_0315.

Our fix was shutting down all Percussion services on our DTS server and applying a backup to the Percussion installation directory to that server. Not an ideal solution, but we’re back up and running.

The original reported issue was due to the DTS server wasn’t identified to be an embedded instance within Percussion folder.  Once we have sorted out that information we were able to start the DTS successfully without any further update.

@David Do you have revert back the DTS folder from backup to have the DTS started after applying the patch?

There is still the known issue where the DTS Windows Services needs to be removed and re-installed after applying the patch.   If the DTS service wasn’t starting after it was patched, that could be why.