Server Restart + Publishing

This post is really two issues; mainly, because they may be related.

We tried stopping and starting Percussion this afternoon to find an error that prevents us from starting up again (below code).

We initially stopped the server because we found that pages were not publishing (see screenshots), either as an entire site or single-page publish. In the logs, a single-page publish came up as failed, but without a reason as to why. After multiple publishes today, pages still show a last published time of yesterday morning.

We really need access to Percussion soon to showcase a preview of the site and also, at some point, to be able to pull it up in its published state.

'Preciate any help with these two issues.

2012-10-18 11:28:07,420 ERROR [] Problem during delivery   
org.springframework.transaction.TransactionSystemException: Could not roll back Hibernate transaction; nested exception is org.hibernate.TransactionException: JDBC rollback failed   
at org.springframework.orm.hibernate3.HibernateTransactionManager.doRollback(   
at org.springframework.transaction.interceptor.TransactionAspectSupport.completeTransactionAfterThrowing(   
at org.springframework.transaction.interceptor.TransactionInterceptor.invoke(   
at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(   
at org.springframework.aop.interceptor.ExposeInvocationInterceptor.invoke(   
at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(   
at org.springframework.aop.framework.JdkDynamicAopProxy.invoke(   
at $Proxy95.findContentTypesForIds(Unknown Source)   
at Source)   
at Source)   
at$Item.commit(Unknown Source)   
at Source)   
at Source)   
at Source)   
at Source)   
at Source)   
at Source)   
at com.percussion.rx.publisher.impl.PSPublishHandler.onJobControl(Unknown Source)   
at com.percussion.rx.publisher.impl.PSPublishHandler.onMessage(Unknown Source)   
at org.springframework.jms.listener.AbstractMessageListenerContainer.doInvokeListener(   
at org.springframework.jms.listener.AbstractMessageListenerContainer.invokeListener(   
at org.springframework.jms.listener.AbstractMessageListenerContainer.doExecuteListener(   
at org.springframework.jms.listener.AbstractPollingMessageListenerContainer.doReceiveAndExecute(   
at org.springframework.jms.listener.AbstractPollingMessageListenerContainer.receiveAndExecute(   
at org.springframework.jms.listener.DefaultMessageListenerContainer$AsyncMessageListenerInvoker.invokeListener(   
at org.springframework.jms.listener.DefaultMessageListenerContainer$   
at Source)   
Caused by: org.hibernate.TransactionException: JDBC rollback failed   
at org.hibernate.transaction.JDBCTransaction.rollback(   
at org.springframework.orm.hibernate3.HibernateTransactionManager.doRollback(   
... 28 more   
Caused by: java.sql.SQLNonTransientConnectionException: No current connection.   
at Source)   
at Source)   
at Source)   
at org.jboss.resource.adapter.jdbc.BaseWrapperManagedConnection.jdbcRollback(   
at org.jboss.resource.adapter.jdbc.WrappedConnection.rollback(   
at org.hibernate.transaction.JDBCTransaction.rollbackAndResetAutoCommit(   
at org.hibernate.transaction.JDBCTransaction.rollback(   
... 29 more   
Caused by: No current connection.   
at Source)   
``` [![](]( [![](](

Just want to add that the error we get when trying to access Percussion is a 503 error.

Also, here is the code just before it says it has been restarted:

2012-10-18 11:55:22,963 WARN [org.jboss.web.tomcat.service.JBossWeb] Failed to startConnectors   
LifecycleException: service.getName(): "jboss.web"; Protocol handler start failed: Address already in use:9992   
at org.apache.catalina.connector.Connector.start(   
at org.jboss.web.tomcat.service.JBossWeb.startConnectors(   
at org.jboss.web.tomcat.service.JBossWeb.handleNotification(   
at sun.reflect.GeneratedMethodAccessor4.invoke(Unknown Source)   
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)   
at java.lang.reflect.Method.invoke(Unknown Source)   
at $Proxy30.handleNotification(Unknown Source)   
at org.jboss.system.server.ServerImpl.sendNotification(   
at org.jboss.system.server.ServerImpl.doStart(   
at org.jboss.system.server.ServerImpl.start(   
at org.jboss.Main.boot(   
at org.jboss.Main$   
at Source)   
2012-10-18 11:55:22,963 INFO [org.jboss.system.server.Server] JBoss (MX MicroKernel) [4.2.3.GA (build: SVNTag=JBoss\_4\_2\_3\_GA date=200807181417)] Started in 16s:149ms   
``` [![](](

How long did you leave before starting the service back up? It looks like the port is still in use, possibly indicating the service was not able to fully stop all associated processes before it was started back up again. Make sure you leave a couple minutes between stopping and starting to allow it to fully shut all pieces down.

Before starting up again, I’ll wait until we get a message back from the server saying the stopping has completed.

If we did start again too early, how can we reboot it? I’ve tried stopping again and waiting 10 minutes before booting up. But I still get the above errors.


Are you on a Linux machine? If so, you can use the command “ps -ef | grep java” to display all the java processes running on that machine. Kill all of the processes running out of the Percussion directory using “kill -9” followed by the numerical ID of the process. This will end all instances of CM1 attempting to run, at which point you will be safe to start back up.

If you’re on Windows, you can use Task Manager to manually end all Java.exe processes running out of the Percussion directory. Alternatively, a tool such as Process Explorer would make it easy to identify CM1 Java processes:… .

Lastly, a full reboot of the machine would accomplish the same objective. Once you have CM1 back up and running, let us know if you encounter additional publishing issues.



Seems like the grep and kill command got everything cleared up and we were able to restart Percussion. Thanks for the help!

Going to see if we can publish now.

Looks like we’re still getting publish failures, and I’m not exactly sure why (see attached).

Again, we tried publishing a single page, and that page says its last publish date is yesterday morning.


I have created an internal support ticket for us to take a closer look at why your publishes are erroring on you. Please check your inbox for that.


Matt, did you receive my message through the ticket yesterday? I know we had an issue in the past with another support ticket where you never received a message notification from us, so I just wanted to make sure you got that this time.

I did, basically saying the ticket has been created. Thanks for checking up on that.

I had sent a message along with the ticket creation. It sounds like that notification didn’t specify that. At any rate, I have resent my message. Sorry for the mix-up!

To update other customers who might be having similar issues, the remaining publishing problems were found to be caused by low disk space on their production web-server. This was the relevant error in their server.log file:

ERROR [] Unable to create directory:

We got on the line with them and assisted with allocating more disk-space for their VM as well and growing their existing partition. After doing this, publishing resumed functioning as normal.