Authentication Error in Firefox when opening content editor with sys_CheckBoxTree

We have a sys_CheckBoxTree control in one of our content editors. When I attempt to create or edit documents with that editor in Firefox, I am getting a popup with this error:

Processing Error: Not Authenticated
This request requires authentication, but the current session is not authenticated. The user session may have expired or the server may have been restarted. You must log back into Rhythmyx to continue.

I assume there’s something about this applet that’s not using the authentication context of the window it’s in (??). I don’t see any errors in the Java console, and it is working correctly in IE. Can anyone provide any clues to debugging or (preferably!) fixing this?


(Rhythmyx version is 6.5.2)


As you probably know by now, the checkboxtree applet is passed a URL of the XML document that describes the tree.

What is that URL, is it absolute or relative? What happens when you try to open that URL in a fresh browser window? (note that Firefox caches credentials as long as ANY windows are open).


[Just added XML to this post - thanks, Dave]
The checkbox tree parameter value for tree_src_url is:


(i.e. relative)

I just tried the following experiment:

  1. Open Firefox
  2. Log into Content Explorer
  3. Open another tab in the same browser
  4. Hit the sub app tree URL (i.e. put in the URL above, substituting the server name plus port and Rhythmyx, to make a absolute URL:
  5. Without any authentication prompt or error, I see the XML for the choices available in the tree:
<?xml version="1.0" encoding="utf-8"?>
<tree label="Sub-Applications">
   <node id="compbio" label="Computational Biology" selectable="no">
      <node id="compbio.compbio_sub" label="Computational Biology" selectable="yes"/>
   <node id="control" label="Control Design" selectable="no">
      <node id="control.moddesign" label="Model Based Design" selectable="yes"/>
      <node id="control.modtools" label="Modeling Tools" selectable="yes"/>
      <node id="control.autocodegen" label="Automatic Code Generation" selectable="yes"/>

   <node id="dsp" label="DSP/Communications Design Automation (DSP/Comm)" selectable="no">
      <node id="dsp.moddesign" label="Model Based Design" selectable="yes"/>
      <node id="dsp.signal" label="Signal and Image Processing" selectable="yes"/>
      <node id="dsp.comm" label="Communications and RF System Simulation" selectable="yes"/>
      <node id="dsp.codegen" label="Code Generation for DSP and FPGA Implementation" selectable="yes"/>

To paste XML, highlight the text and press the “HTML” button (it looks like a pair of angle brackets <> ). It’s the second icon from the right in the toolbar.

Just tried another experiment - after re-reading your post, I realized you may have meant that I should close the browser and then try hitting the app URL in a fresh browser window. So, I did this:

  1. Closed all Firefox windows
  2. Hit the URL:
  3. I was prompted to login with the Rhythmyx login page, just like the content explorer.
  4. I successfully logged in and could see the XML for that tree (as in my test in the previous reply).

Since this forum query hasn’t turned up a solution, I am going to report this issue to tech support and see if they can help with it. Meanwhile, if anyone has any additional suggestions about how to solve this, please let me know.


I don’t see anything that you are doing differently from what we do in our demo systems. Clearly there must be something different, but it’s not obvious what.