Bulk Upload "Approve" checkbox not showing for all users

We have two workflows in our CM1 instance:

* Default Workflow
* Asset Workflow

All users are members of the Asset workflow, which has full workflow permissions. The Asset workflow is assigned to a single folder in the Assets folder tree.

A user who is a member of the Assets workflow, but not the Default workflow, never sees the “Approve” checkbox on the bulk upload tool, even if they are uploading to the folder in which they have permission to approve content. (We do this because we need to restrict some content on the site from certain users)

Is there a way for us to make this checkbox visible for these users? Or have I just gone about this all wrong!?



Hey Oliver,

This looks to be a bug, and I’ve gone ahead and filed it in our internal system. If you grant this role Approve permissions for the Draft state of the Default Workflow, the checkbox is present, otherwise it won’t show up, regardless of the user’s permissions in the asset library. Thanks for bringing this to our attention!