Bulk uploader not publishing documents when checkbox is checked

I’ve noticed that when user’s are uploading files, the bulk uploader is not approving the asset’s automatically. I’ve done a full site publish after the upload and they are still not approved. We are having to manually publish each document.

I’ve noticed when looking at doucments after they are uploaded, they are showing pending.

Hey Matt,

When “Approve assets” is checked off for the Bulk Upload gadget, the assets should be put into the Pending workflow state. When content is Pending that means it’s approved, and will be published out on your next full site publish, switching the content to the Live workflow state.

Note that if the content is being created as an asset type other than File (PDF, Doc, etc.) or Image, the assets will only be published out if a page using the asset is also published.

Hey Nathaniel,

I’ve done quite a few publishes and it’s not publishing people’s uploads at all. I’m having to go back and manually publish them one at a time right now. Is there not a way that I can make them automatically publish when the user uploads them?

Hi Matt,

Due to workflow, assets cannot be made to automatically publish after uploading them. Have you run a full site publish since the bulk upload? That should publish all of your assets and pages in the “pending” workflow state.


I have ran multiple site uploads since our users have uploaded their files back in Feb. Their files were still showing to not be live.

We have had to go back in a publish them individually since we went live on Monday and had to have the files available.

Hi Matt,

What kind of assets are these? Are they images and/or PDF’s?


Images, PDF’s, DOC, DOCX, XLS, XLSX, PPT, and PPTX.

Hi Matt,

One thing you may want to quickly check is if folder security is enabled on the root folder that the assets are being uploaded to. You can check by clicking on the root folder in the finder and then using the gear icon in the utility nav. You will want to check whether assets in that folder are restricted only to a certain site.


I do have user rights assigned to folders. People are only uploading items to folders they have access to.

Hi Matt,

When you have a chance, I’d like you personally to follow the process below, to rule out any chance that some of this behavior might be the result of user error, or some unknown variable we haven’t thought of yet:

  1. Upload a PDF file to the /Assets/uploads directory with Approve assets selected and the asset type set to File

  2. Single click on the asset in the Assets library and ensure that the Status is listed as Pending

  3. Run a full site publish of your site in CM1, ensure that it completes without failures

  4. Click on the asset in the Assets library again see if the Status is now listed as Live

  5. Check on your server’s filesystem to see if the file has been placed in the [site_root]/Assets/uploads folder.