Can you install the Developer Tools on Linux?

One of my two PCs has a Linux distro installed and I use that one a lot. Is it possible to install Workbench and Server Admin on it?

It’s not “officially supported”, but we do have a couple of people in our PSO team who run on Linux, so it does work (at least most of the time).


I suppose they run it on WINE?

The Workbench is an Eclipse plugin, and if you install a recent version of Eclipse on Linux, it ought to work. You will, of course, need to install the plugin separately (we provide the files in a directory on the server installation).

The Server Admin is a Java program, which can be launched directly, or you can use the provided launcher under Wine.

I don’t run this way (I run linux servers with a windows client), so I cannot give you much help on the details.


The Server Administrator can also be run as an applet. A button to launch this applet is available in the Content Explorer on the Workflow tab.

Thank you gentlemen…

Can someone give me some additional steps on how to run this in eclipse in linux? I managed to get the zip files in and I see it as a plugin but no matter what I do I can not seem to get it to run

I don’t run the Workbench on Linux, but I do run it on Mac and it works fine. All I did was get Eclipse Europa w/ WTP bundled. Then I just copied the Percussion files into the plugins directory and it worked fine. I’m guessing this same thing should work for Linux.

I run Workbench on Fedora 16 64-bit. Had to dig back in the Eclipse archives and get the 3.3.2 WTP bundle to make it work. Actually runs better for me than the official Windows version of Workbench. Although in both Windows and Linux I experience total freezes of the Workbench when working with XML apps but I have found ways to coax WB back to life when this happens.

Server admin also works fine in Linux, just write a script to call java with the correct classpath and main class (the .lax file provides all the hints you need). Sadly MSM is not fully functional for me, the browser for choosing custom file dependencies won’t open.