Copy functionality Error - Javascript

When i go to copy a page in CM1, in any of my directories, the page copies but I get the following javascript error.

Hi Matt,
Have you applied the 3.1 patch already? If so, have you cleared your browser cache after applying it?


Hi Jon,

I have applied the patch already and yes I have cleared the cache on both machines that I tried this on.

Hi Matt,
Thanks, also are you using the same browser on those machines?

No, Firefox and Chrome. Tried it in Internet Explorer and the same problem.

Hey Matt,

Just to clarify, as far as you can tell, is the copy of the page that does get generated fully functional and usable? Can you access all of the local content on the copied page? Thanks.

As far as I can tell, the page is fully funtional.

Thanks, Matt. Because we can’t reproduce this issue locally, I’m going to open a support ticket for this so I can take a look and see what errors are being logged on the server side. Please check you inbox shortly.

We found that this error is being caused by a change we made to how templates are handled internally, and will affect pages created in the system before version 3.0. The error itself is harmless and is not an indication of any real problem, so it can safely be ignored. We plan to fix this in our next release.