Copying an application

Part of the recent webinar involves creating a preview which only shows public content.
To do this I need to copy the rxs_cxSupport application.
Can I do this from workbench or do I need to copy the files on the server? I can select Copy but Paste is always grayed-out. And if I copy all the icons and paste them into a new application it doesn’t seem to like that either.
Any ideas of what’s going on?

… or you could have your preview velocity template find the most recent public revision and render the production template using that revision.

Something along the lines of (warning: untested code follows - probably would only work in 6.7 anyway):

#set($publicrevision = "$!sys.item.getParameter('rx:sys_publicrevision')")
#if($publicrevision != "")
#set($newparams = $rx.asmhelper.combine($sys.params,"sys_revision"))
#set($results = $rx.asmhelper.assemble($sys.assemblyItem,$sys.asm.findTemplateByName("[I]TEMPLATE_NAME[/I]"),$newparams)
<p>This content item has yet to be published.</p>

oops… typo…

that’s supposed to be: $rx.asmhelper.combine($sys.params,“sys_revision=$publicrevision”)

To answer the original question - you can copy an app using the workbench. Select what you want copied, right click and choose copy. Then select the folder where you want the copy, right click and choose paste.

Thanks, Paul … I’d tried that but only at the System folder level, not right back on the Applications folder. That’s worked.

Rushing … there’s some interesting Velocity there. Some of your idea I might be able to use elsewhere!

Appreciate both your comments.