CSS classes not displaying in wysiwyg editor

I’ve edited the css to my theme and uploaded it. yet when I go to the style drop down selector in the editor, my style options don’t don’t show up in the list. Do I need to associate the css file to my template differently?


You are referring to the styles that appear in the Rich Text Editor such as “Body text 1”, etc., correct? Now, are you trying to add additional styles to this list, or work with the existing styles? If it’s the former, unfortunately this is not possible at this time. However, the 14 built-in classes are not used in any other context in CM1, so you are free to style them however you like in your style sheet without fear of harming anything else. For you reference, here are the 14 classes you can style which are tied to the styles that are selectable in the editor:







Let me know if this helps, and if I’m understanding your intentions correctly here.

Thanks. This helped. Is it best to add these CSS classes to my own theme CSS? Or do I just update the Percussion CSS file?

Also found a related issue. When the content was cut/paste from the old site into the CM1, it looks like there’s ugly hard coded font colors and other classes from the previous site etc. Is there an easy way to strip out all the garbage as seen below?

Faculty Scholarship


Yes, add them to your theme’s CSS file.

I cannot see what you have included after “as seen below” besides the text “Faculty Scholarship.” Was there supposed to be HTML code there? If so, for HTML code to appear properly on here, you will need to wrap them in tags like this:

 Code goes here. 


Great. Thanks.

The code I wanted to share is below now. When we’d copy/pasted the text from our current site to CM1, it looks like it took the css style information for that text and wrote it into the code in the new CM1 site (but hard coded). I don’t want the color, font family etc. in there. Is there a way to globally take it out? Our editor ran in to this when pasting from the web to Word to edit, then in to CM1 (it still brought the font info in). I’ve had her start to take it to Dreamweaver now and turn off the styles before pasting in to CM1. Is there a better way to do this? Thanks!

Wildcat Scholarship **```**

FYI - Initially we didn’t notice this as we thought it was just using the CSS from our theme on CM1 to style the text.

When pasting text into an editor, it only accepts what is copied and pasted into it. That means, if you copy something that is HTML in a web page, and paste it into any rich text editor, the styles will come with it. Word behaves the same way and preserves styling when you copy HTML.

This situation only typically occurs when you copy something with styles inline already. If you copy out HTML that uses a class for styling, for instance, it typically will not have this effect. You can check the markup of the page to see if that is the case. If that is the case, there is no way to avoid it as what you are copying contains the inline styles.

If it’s something that is happening because of Word, we can only suggest pasting into something different first, or try directly pasting into the editor. Additionally, there is no easy way to remove it globally. That would be a manual process to identify and remove. You could also try viewing the source and copying only what you need from the source, ignoring the inline styles.

When you copy directly on a webpage, however, whatever you highlight and copy brings the actual HTML markup that represents that into your clipboard.

Thanks Daved. I’ll double check, but it didn’t look like it was inline when I compared earlier. Thanks again.