DB Publishing to MySQL & SSH + DB ports

We are going to implement non-standard DB publishing to MySQL and I have setup the system to do so by adding MySQL driver and seting up the rest of the components (rx-ds.xml mod and tablefactory changes), all works fine with my local instance of MySQL(jnditest.jsp shows my target DB OK), however it throws connection exceptions if I try to connect to the remote MySQL - the problems I face now are:

  1. None of the MySQL options show in JNDI or Connection fields in Table Definition builder tool nor in Server Admin Datasources tab - this is true for both, local or remote.
  2. No way (at least what I’ve tried so far) to add connection string that will include both SSH host:22 -/uid/pass and DB host:3306(mysql port) -/db-uid/pass

I’ve tried to set an seperate port - L8555 to accept the dual connection through PuTTy - doesn’t work.
What would you sugggest I do here (ex. from rx-ds.xml):



It seems like I’m missing the SSH connection string before connecting to DB itself. Or should we just enable some other port on the Target box (other than default 3306) and open HTTP to it from remote.

Thanks in advance for your help.


Does the failure happen in jnditest.jsp as well as the publisher, or does jnditest.jsp work where the publisher fails?


Issue #2 is resolved - we are connected to the remote OK - with current settings shown earlier.
If anyone interested - all it was is the MySQL instance config to accept remote connections through port:3306 and not only localhost.
Now - the issue #1

Although I have OK on jnditest (Dave - no publishing yet, I think it will be ok there) - I have no values for MySQL driver or schema in TD builder or in Server Admin Datasource tab.
It connects ok but other tools don’t get the path, although I did provide the classpath in runTD.bat to point to the driver as such:

%EXECJAVA% -classpath 
server/rx/lib/db2jcc.jar;[B]../server/rx/lib/mysql-connector-java-5.0.8-bin.jar;[/B]../server/rx/lib/db2jcc_license_cu.jar;../server/rx/lib/saxon.jar; com.percussion.tablefactory.tools.PSTDToolDialog

no file integrity broken no linebreaks.

the db driver file is there along with all the rest of em.
rxtablefactory.jar is replaced to include PSJdbcDataTypeMaps.xml

??? any idea