Failed to add deployable jar

I don’t think this startup error message is actually affecting anything, but I have an idle curiosity about what it means (6.5.2):

15:59:33,512 WARN  [JARDeployer] Failed to add deployable jar: file:/Rhythmyx/AppServer/server/rx/tmp/deploy/ error in opening zip file 
        at Method)
        at<init>(Unknown Source)
        at java.util.jar.JarFile.<init>(Unknown Source)
        at java.util.jar.JarFile.<init>(Unknown Source)


It seems to be referring to one of the include files in my resources directory, /Rhythmyx/AppServer/server/rx/deploy/My_Site.war/includes/

You’re correct, this is the JBoss JarDeployer that is giving you this message.

Are you deploying the application as a WAR file, or have you expanded it?

It should be plain HTML. I get the same error with a CSS file in that subdirectory.

Check that you don’t have any stray files or sub-directories in the /Rhythmyx/AppServer/server/rx/deploy directory. Any file in that directory is assumed to be a deployable resource of some kind. Any sub-directory of the deploy directory must have a proper extension (e.g. “.war”) or JBoss assumes it is an archive and tries to unzip it.

If that doesn’t help, try shutting down the server, deleting the contents of the /Rhythmyx/AppServer/server/rx/deploy/tmp directory, and then restarting the server.

Yes, that fixed it. One of my sub-directories didn’t have a .war extension.