Inline image publishing problem

When publishing pages that contain inline images, the img tags aren’t resolving properly. For example, a published page contains the img tag below.
Any idea why this is happening?

<img alt="" inlinetype="rximage" rxinlineslot="104" src="" sys_contentid="4827" sys_dependentid="4827" sys_dependentvariantid="333" sys_folderid="" sys_relationshipid="228665" sys_siteid="" sys_variantid="333" />



Do you have a site_folder_assembly and publish context set up for this content type and its binary template?

Actually, our publish and assembly contexts are one and the same. However, for the sake of testing, I created two separate contexts and it didn’t fix the problem. I added the same image to another content item of different content type and the image path published correctly. The publishing of both html files and the image file seem to be okay otherwise. Any other suggestions?


It is curious to me that the src has a sys_context of 0 when it is published out… Shouldn’t that be 301? (to me, if a regular template was doing this, it would indicate an error with the code of the inline template and my general response would be to delete it and try again). I can’t offer more support regarding images as the way we do inline images is similar to any inline template (with divs and spans) and not what was shipped out of the box…

Thanks jitendra,
I tried inserting an inline template and this is what published out. The same thing is happening with the sys_context being 0.
Anything else pop out at you?

<div class="rx_ephox_inlinevariant" contenteditable="false" inlinetype="rxvariant" rxinlineslot="105" rxselectedtext="" style=" display: inline;" sys_dependentid="50906" sys_dependentvariantid="1249" sys_folderid="" sys_relationshipid="228725" sys_siteid=""><img alt="logo" src="" sys_contentid="50906" sys_variantid="1238" /></div>

That to me implies that some thing was misconfigured when setting up the field in the content type (ie. the system doesn’t think that it needs to check any relationships in the field). I would check to make sure the check box for “allow inline links” is checked (heh…). So in workbench > Content Design > Double click [Your content type] > Click on the “…” for your control for that particular field (which should be “sys_EditLive”).
That choice should be under the “Field data properties” section. We have that and the “Clean up broken inline links” checked as well.

Hallelujah!! We had Allow inline links checked but did not have Clean up broken inline links checked. And checking that fixed the problem.
In my testing I actually compared this content type with another working content type and clearly this one check mark I missed.

thanks a million!