Is a tiff image supported format?

In attempting to upload images, I could not upload a tiff image. I tried bulk and individual upload. Is it possible this is not a supported format?

We managed to upload the tiff file as a ‘file’ format instead of an ‘image’ format. This seems to be a good work around for now, as the tif file still functions as one would expect’s (opens in new window for user to right-click to save-as).

Hi Heather,

Tiff image files are supported in CM1. I have encountered no issues uploading and linking to a Tiff image (.tif and .tiff) through the Bulk Upload gadget (using the Image asset type drop-down option), Image widget, or uploading through the Finder to Web Resources. Can you clarify the steps you took which led to your issue?


Both using bulk uploader and uploading an individual file from the create new asset on top right toolbar produced errors while attempting to upload tiff files. I also tried re-saving the tiff image, as sometimes in the past that has fixed jpg and pdf upload issues.

Steps for Bulk: chose folder, chose 3 tif files, results:

Steps for Individual: navigated to folder, chose new asset - image, selected next, gave it a title, selected one of the three images I was previously attempting to upload via bulk and the first error message I get is “Possibly invalid image. Unable to determine image height and width.”

and I figure oh well, no place for me to tell it the height and width, so i click save and get:



Great info, thanks! I tested this in 2.6 and 2.7 to be sure, and it still works for me. I’m going to guess that the issue for you lies with your Tiff’s file size (19.45MB). I haven’t found any documentation to verify this, but I’m going guess that Image assets types are limited to a smaller size than other file types (presumably something under 19MB), and that’s why it only goes through as a File asset type. I will let you know if I can confirm this.


Thats great thank you.

Thanks Nathaniel for your help on this.


I’ve had a chance to test this further, and it actually doesn’t appear to be an issue with file size for image Assets, but rather a compatibility issue with the Tiff image format as you originally thought. First, I was just able to upload a 20MB PNG as an Image asset with no trouble, so I played with different conversion and compression modes for Tiff images, and this time I encountered the error message you saw more often than not.

For now, your method of uploading the image as a File asset is one workaround, if you want the image to behave as you described in your first reply. Of course, the other option would be just to convert the image into a fully supported image format before uploading (PNG, JPG, etc.).

I hope this clears things up. Thanks again for highlighting this for us.