New DTS: Could Not Connect to Publishing Server

We have migrated DTS servers recently, but cannot connect to the new publishing server (we get “Cannot Connect to Publishing Server. Please check publishing server connection.”)

We’ve copied the DTS install file for file (compressing the install and untarring as a new directory). 

The only thing that’s changed is the IP address, which we’ve reflected in the delivery-server.xml and the publish configuration itself. 

What are we missing?

Hi Matthew

Could it be the DTS port issue that we may need to add in the firewall manager to exclude?  Were you able to access the DTS url from your machine?

Ive added 8443 to the open ports so both servers now have these ports open 22, 80, 443, 8443, and the CM1 server has 9992 open.

If the publishing server is configured for ftp publishing then we need to open up port 21 as well.  Please open port 21 as well if ftp publishing. 

I have opened up port 21 on  both servers, but am still getting the same error when attempting to publish. I noticed the configuration had port 22 set on it, so I tried port 21, and that didn’t work either.

Hi Matthew

I’ve created a support ticket to troubleshoot this issue at your end. 

The connection to ftp publishing server was failing with following trace in server.log file:

ERROR [] SFTP Connection Check Failed to connect
com.jcraft.jsch.JSchException: Algorithm negotiation fail

This issue was due to outdated jsch0.1.48.jar file in CM1.  To solve this issue, updated the jar to jsch0.1.54.jar version in Percussion/AppServer/server/rx/deploy/rxapp.ear/rxapp.war/WEB-INF/lib folder.  This jar will be updated in next CM1 patch release. 

The jsch0.1.54.jar can be downloaded using below link: