Does anyone know how to stop logging information stored in PSLOG and PSLOGDAT. These tables are growing to over 7 million rows in 48 hours. With the auto-delete feature turned on, the delete statement that it runs takes 20-30 minutes. This occasionally wreaks havoc with our dbms.

In the server admin tool, I’ve disabled all the logging, but data is still being stored in those two tables.

The logging config in the server admin controls the default logging for all apps. In addition to this, each app can enable other logging.

If your tables are acquiring that much data, some app must have full app logging enabled. You need to check the logging for all apps and disable logging on those that have anything other than error (error is good to leave enabled, it occassionally provides useful information when a problem occurs and doesn’t take up much space/time.)

You could open each app individually and check its logging. An easier approach is to grep ‘PSXLogger’ from [rxroot]/ObjectStore/*.xml. Look for anything set to yes, particularly logXXXUserActivity. Edit apps where you find an issue in the workbench.

This may improve performance a little too.

Thanks to your suggestion, I think I found the culprit. I followed your advice, only to find that we weren’t configured to log anything other than appStartStop and Errors.

So then I opened one of the xml applications and came across the PSXTraceInfo element.

<PSXTraceInfo id="0" traceAppHandlerProc="yes" traceAppSecurity="yes" traceBasicRequestInfo="yes" traceConditionalEval="no" traceDbPool="no" traceEnabled="no" traceExitExec="no" traceExitProc="no" traceFileInfo="no" traceInitHttpVar="no" traceMapper="no" traceOutputColumnWidth="80" traceOutputConv="no" tracePostExitCgi="no" tracePostExitXml="no" tracePostPreProcHttpVar="no" traceResourceHandler="yes" traceResultSet="no" traceSessionInfo="no" traceTimestampOnlyEnabled="no"/>

I think that the majority of the entries in my PSLOG and PSLOGDAT are due to traceBasicRequestInfo=“yes”. I’ll be testing that theory out, and I’ll report back.

Tracing should not cause any entries in the log (unless a trace was causing an error.) However, you should disable all tracing unless you are currently working on a problem as it adds overhead.

Look at the LOG_TYPE column in the PSLOG table. Error, appstart, appstop are 1, 4 and 5 respectively. If your server is not being restarted frequently, then either all the other entries are 1’s, (which bears looking into why you are getting so many errors) or you missed a log setting in your recent search. If you find other numbers, report them here and I can tell you what to search for to quickly find the culprit.