Removing Fonts from the ephox control

Has anyone tried removing fonts from the ephox control by editing the <rxroot>/rx_resources/ephox/elj_config.xml ?

I can’t seem to get the ephox control to read the configuration. I tried clearing the java and browser cache along with rebooting with no luck.

Yes, it works for me though I remember wondering if it ever would. I didn’t even have to reboot or clear the caches. The sys_EditLive control property for the callout field in my Brief content type for config_src_url has the literal (other value) value of …/rx_resources/ephox/elj_config.xml

I’ve attached my config file in case that helps.

Thanks for posting your configuration file. I tried a portion of your configuration but still see the address formatting in the ephox control.

I’m not sure why my environment is not responding to the changes.

As a troubleshooting step I deleted the elj_config.xml file and the ephox control still comes up as usual.

I did a restart of the Rhythmyx Daemon also with the same results.

Should not make any difference but our system is running on redhat linux.

Also, we have the code tab turned off for regular users and only available for admins. When I look at the webpage source here is the part for the xml config file:
// add a new editor object to the object array. See rx_ephox.js for prototype.
var ed = new Object(); = “callout”;
ed.config = “…/sys_Ephox_support/config.xml?config=…%2Frx_resources%2Fephox%2Felj_config_admin.xml&field=callout&sys_lang=en-us&isReadOnly=no”;
ed.inlineLinkSlot = “103”;
ed.inlineImageSlot = “104”;
ed.inlineVariantSlot = “105”;

     var ix = _rxAllEditors.length;
     _rxAllEditors[ix] = ed; 

I’m thinking the admins may be using a different config.xml file vs our regular users.

To get the code tab to go away for regular users we preformed the followings steps:

  1. Shutdown the server.
    > 2. Replace the rx_templates(/cms/Rhythmyx/rx_resources/stylesheets/rx_templates.xsl)
    > 3. At this point, in rx-templates it is still being referenced to
    > “rx_ephox.js” file. So change the name of CUSTOMrx_ephox.js to
    > You will see that it is being repointed to rx_ephox.jsp under
    >editlive folder :
    > <psxctl:FileDescriptor name=“rx_ephox.js” type=“script”
    > mimetype=“text/javascript”>
    > 4. Restart your server.

I figured it out. Only non-admins have the elj_config.xml applied to their session.

The file does not appear to be applied for admins. I think this has to do with some modifications we made so that non admins do not have the code tab in the ephox control.