Unable to Add Regions/Widgets in Templates

We’ve noticed (at least three times) that templates will not allow us to drop new regions and widgets. Then when we try to remove sections to rebuild it, it switches to a view that looks very much like the content tab (even though we’re currently in the design tab) after removing exactly 2 regions/widgets.

Likewise, in a page’s design section, we cannot add regions/widgets.

Has this been confirmed before? It happened to us very recently on a template with a lot of elements, and we’d hate to have to rebuild it from scratched (this is how we solved it before).

It happened prior to upgrading to CM1 2.7 and now after.


CM1’s templates follow a set of rules concerning placement of widgets and regions, to ensure consistency and flexibility. Please take a look at this help document to verify that your intended layout arrangement follows these rules, and, if not, to see what your redesign options would be to achieve your desired layout:

Also note that, when editing pages (as opposed to templates), you can only add widgets to unpopulated regions through the Layout tab. Therefore, regions that already house widgets on the template level are locked on the page level.

As to your issue with the Layout tab switching to a view similar to the Content tab after removing two regions or widgets, I will have to test this out to see if I can recreate this behavior. Thanks for the tip.



The following images show an empty region in the template we spoke of, the intended placement of an HTML widget in that region, and there being no highlight to indicate that it will be dropped there. As such, when we let go of the widget to place it, it does not occupy the region. This is true everywhere on our template.

The final screen shows the switch to a content-looking page despite being in design. This happens after removing two regions or widgets.


Very strange. Your HTML widget placement appears completely valid there. I have been testing this, the layout tab reverting to a content view, and your issue with adding section links to the navigation in various browsers in a Mac environment, and I still have been unable to recreate any of these issues locally. If you haven’t already, do you (or someone with access to your CM1 user interface) have the ability test these issues on a different, non-Mac, machine, to make sure that these issues are reproducible outside of your local environment?



Do you have any scripts being included on this page? Try going to View > Disable Javascript and see what the behavior on the template is like.

Ah, that fixed it (well, it enables us to drop widgets in regions).

Thanks. I wonder what JavaScript isn’t allowing us to do so in the first place.

Are you including an external JQuery or Prototype library? We have jQuery included as part of the base and sometimes additional external libraries can conflict. Especially in the case of using another jQuery library, since it will already be bound for the interface. If this is the case, with another jQuery version, you can remove the reference if you don’t need something that is brand new to that release. Otherwise, you can use the jQuery.noConflict to release the variable and set your own.

I was just having this exact problem and am glad I found this post :slight_smile: