Upgrade to new CM1 version and not Site Search no longer works

We upgraded to 2.13 and had major issues. Then upgraded to 3.0 and now our Google Site Search no longer works. Need help. Additional note. This is an IE issue. FF works. Chrome Works.

Hi Jerome,
Is it occurring on a specific version of IE? The reason I asked is that I was able to use the search successfully on IE9 and IE9 in compatibility mode.

Hey Jon,
I am on IE 9.0.8112 and IE 8.0.7701.
Both worked before the upgrade and neither do now. Compatibility mode breaks so many things on the layout of the site it is almost unusable.

  • JB

Hi Jerome,

I am also encountering no obvious issues with search on your site in IE 7 through 10. Have you tested this from more than one machine, or possibly tried clearing your browser’s cache before searching? Also, can you describe in what way search is not functioning? Is the search button simply not active, or is there something wrong with the output on your results page? Thanks.

Hey Nathaniel, I have tried on two different computers and cleared the cache. The issue is that when I type in a search term, the page refreshes and no results are returned. The page renders fine, but the content area where results are to be displayed do not appear.


Because we cannot reproduce this issue on our end, I wonder if it could be related your local security settings for IE, which may be blocking cross-domain connections (to Google, in this case). Under the Security tab in IE’s Internet Properties, try setting the security level for the Internet zone down to the default level of Medium, and then apply your changes. Let me know if this makes any difference.

Nathaniel, Tried setting security to lowest setting, rebooted browser, tried search again and still no display of results. I went to my laptop and tried with my hotspot so I would be off our internal network, received the same results until I tried searching a second time and then results displayed. I close everything down, tried to search again and again received a blank results area until I refreshed the browser. Tried same process on my desktop (which is on internal network) and received only a blank results screen. I’ll follow-up with my IT group to see if any updates or changes have been made for the network but the refresh issue outside the network is still concerning. All search functionality worked fine prior to our upgrade to v2.13 or v3.0.

Jerome, let me know if your IT group has any insight into this. Based on the fact that this works fine on our end and that you’ve replicated our success at least once outside of your internal network, is does sound like we’re narrowing this down to some type of networking issue. I also would be curious what the response code is for requests sent to www.google.com/cse from IE browsers that are failing – to determine this, you can access the network trace tool built into IE by hitting F12, selecting the Network tab, and then hitting “Start capturing” just before initializing a search.

Here is the report it generated when I did a search for the term Analytics.

Jerome, it looks like that didn’t capture the GET requests to www.google.com that we’re interested in seeing. Your search term might have filtered them out. However, I’m more curious to see what the feedback is from your IT group, as that still seems like the most likely reason to me for this issue. Aside from your WiFi hotspot test, can you or anyone else try this from another entirely separate network?